aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>1998-09-20 00:21:56 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>1998-09-20 00:21:56 +0000
commit1231bd9a029002f7774e6b556b17a082a8853a10 (patch)
treeb856357e221722051b252b5fde9ec6882b174bd1 /configure.in
parentce1af9e43d2e974069cc2d1e821ecc769fc8d820 (diff)
* Refined LD_LIBRARY_PATH checks.
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@18 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 17 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index b881a69958..8d8f4f5603 100644
--- a/configure.in
+++ b/configure.in
@@ -1,17 +1,28 @@
-# $Id: configure.in,v 1.3 1998/09/17 02:01:46 gerald Exp $
+# $Id: configure.in,v 1.4 1998/09/20 00:21:56 gerald Exp $
dnl Process this file with autoconf to produce a configure script.
AC_INIT(etypes.h)
AM_INIT_AUTOMAKE(ethereal, 0.3.16)
+dnl Check for CPU / vendor / OS
+AC_CANONICAL_HOST
+
dnl Checks for programs.
AC_PROG_CC
-# If LD_LIBRARY_PATH is defined, add it as a link directory.
-# This should help Solaris users.
-if test x$LD_LIBRARY_PATH != x ; then
- LIBS="$LIBS -R$LD_LIBRARY_PATH"
-fi
+# If we're running Solaris, and LD_LIBRARY_PATH is defined, add it as a
+# link directory.
+case "$host_os" in
+ solaris*)
+ AC_MSG_RESULT(You appear to be running Solaris. Checking for LD_LIBRARY_PATH...)
+ if test x$LD_LIBRARY_PATH != x -a ; then
+ LIBS="$LIBS -R$LD_LIBRARY_PATH"
+ AC_MSG_RESULT(Added LD_LIBRARY_PATH to run-time linker path)
+ else
+ AC_MSG_RESULT(You don't have LD_LIBRARY_PATH defined. This may cause trouble later on.)
+ fi
+ ;;
+esac
# GTK checks
AM_PATH_GTK(1.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS" LIBS="$LIBS $GTK_LIBS",