aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>1999-12-28 04:40:24 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>1999-12-28 04:40:24 +0000
commitc5bdf57e197532bb47a4810027e2f9029205737d (patch)
treeaff439d265cafb7bc1a163a088fef234d3db058f /configure.in
parent6341561afccac1328a278b54558b42608565de65 (diff)
Add support for "--with-plugindir=<plugin install dir>" to configure.
Make the default plugindir $(libdir)/ethereal/plugins/0.8. Ethereal now looks for plugins in the following directories: /usr/lib/ethereal/plugins/0.8 /usr/local/lib/ethereal/plugins/0.8 $plugindir (if different from above) $HOME/.ethereal/plugins git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@1382 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fd0af0b4bf..f2a55dbf5b 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.67 1999/12/26 22:37:19 gerald Exp $
+# $Id: configure.in,v 1.68 1999/12/28 04:40:06 gerald Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -273,6 +273,28 @@ AC_CHECK_FUNCS(getprotobynumber gethostbyname2)
dnl blank for now, but will be used in future
AC_SUBST(ethereal_SUBDIRS)
+dnl check for plugins directory - stolen from Amanda's configure.in
+AC_ARG_WITH(plugindir,
+ [ --with-plugindir=DIR install plugins in DIR],
+ [
+ case "$withval" in
+ "" | y | ye | yes | n | no)
+ AC_MSG_ERROR([*** You must supply an argument to the --with-plugindir option.])
+ ;;
+ *) PLUGIN_DIR="$withval"
+ esac
+ ],
+ : ${PLUGIN_DIR=$libdir/ethereal/0.8}
+)
+
+PLUGIN_DIR=`(
+ test "x$prefix" = xNONE && prefix=$ac_default_prefix
+ test "x$exec_prefix" = xNONE && exec_prefix=${prefix}
+ eval echo "$PLUGIN_DIR"
+)`
+AC_DEFINE_UNQUOTED(PLUGIN_DIR,"$PLUGIN_DIR", [Plugin installation directory])
+AC_SUBST(PLUGIN_DIR)
+
dnl libtool defs
AC_LIBLTDL_CONVENIENCE(libltdl)
AC_LIBTOOL_DLOPEN