aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2000-01-21 08:44:40 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2000-01-21 08:44:40 +0000
commit96e43dc6b4ddb98dec9a80b9ca15538002e9c5fc (patch)
treee5fd1fad929b6f019762dc506a84f5cb02f45f8c /configure.in
parent159648f5978c73b1f7f2639877b808505044a7fe (diff)
Add stuff to add platform-specific compiler flags; currently, we have
only flags for HP's ANSI C compiler, as suggested by Jost Martin. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@1517 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 29 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e451efc8bf..78c004baa6 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.79 2000/01/21 06:18:16 guy Exp $
+# $Id: configure.in,v 1.80 2000/01/21 08:44:40 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -41,6 +41,34 @@ else
fi
#
+# Add any platform-specific compiler flags needed.
+#
+AC_MSG_CHECKING(for platform-specific compiler flags)
+if test "x$GCC" = x
+then
+ #
+ # Not GCC - assume it's the vendor's compiler.
+ #
+ case "$host_os" in
+ hpux*)
+ #
+ # HP's ANSI C compiler; flags suggested by Jost Martin.
+ # "-Aa" for ANSI C
+ # "-Ae" for extensions to ANSI, for "long long".
+ # "+O2", for optimization. XXX - works with "-g"?
+ #
+ CFLAGS="-Aa -Ae +O2 $CFLAGS"
+ AC_MSG_RESULT(HP ANSI C compiler - added -Aa -Ae +O2)
+ ;;
+ *)
+ AC_MSG_RESULT(none needed)
+ ;;
+ esac
+else
+ AC_MSG_RESULT(none needed)
+fi
+
+#
# Arrange that we search for header files in the source directory
# and in its "wiretap" subdirectory, as well as in "/usr/local/include",
# as various packages we use ("libpcap", "zlib", an SNMP library)