aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorobiot <obiot@f5534014-38df-0310-8fa8-9805f1628bb7>2004-04-14 18:42:19 +0000
committerobiot <obiot@f5534014-38df-0310-8fa8-9805f1628bb7>2004-04-14 18:42:19 +0000
commitd9a0533514bd93a2906effeffee43bd1f7202341 (patch)
tree31673e9d7c268849593fecac0a5b0f414793bb00 /configure.in
parentedbc426cddbf6e20300fb5253cde464aa42af66f (diff)
At last compiling on CygWin works again! Added the missing PCRE and GLIB
libraries to libftypes. Provide caching of computed configure tests. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@10600 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b73a01945d..33f3adb648 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.254 2004/03/27 11:52:51 jmayer Exp $
+# $Id: configure.in,v 1.255 2004/04/14 18:42:19 obiot Exp $
#
AC_INIT(etypes.h)
@@ -133,6 +133,14 @@ else
CFLAGS="-no-cpp-precomp $CFLAGS"
AC_MSG_RESULT(Apple GCC - added -no-cpp-precomp)
;;
+ cygwin*)
+ #
+ # Shared libraries in cygwin/Win32 must never contain
+ # undefined symbols.
+ #
+ LDFLAGS="$LDFLAGS -no-undefined"
+ AC_MSG_RESULT(CygWin GCC - added -no-undefined to LDFLAGS)
+ ;;
*)
AC_MSG_RESULT(none needed)
;;
@@ -978,6 +986,9 @@ then
fi
AC_SUBST(ENABLE_STATIC)
+dnl Save the cacheable configure results to config.cache before recursing
+AC_CACHE_SAVE
+
AM_CONFIG_HEADER(config.h)
AC_CONFIG_SUBDIRS(wiretap)
AC_OUTPUT(