aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2001-01-18 09:54:09 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2001-01-18 09:54:09 +0000
commitbd19f14df588ce8277d03685fe113ba3258d5d9c (patch)
tree24ae31cc77997f873b97e21f46fffbdcdca55eb2 /configure.in
parent61f9fa439f25320f4f7639d59e8562e07bb6f3fe (diff)
Changes to look for SSL library for those who have UCD SNMP compiled
with SSL support, from Andy Hood. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@2919 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b87fba5704..64a5f4ad4d 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.111 2001/01/12 04:06:22 gram Exp $
+# $Id: configure.in,v 1.112 2001/01/18 09:54:09 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -317,6 +317,18 @@ if test "$ac_cv_header_dlfcn_h" = yes ; then
AC_DEFINE(HAVE_PLUGINS)
fi
+dnl SSL Check
+SSL_LIBS=''
+AC_MSG_CHECKING(whether to use SSL library if available)
+if test "x$enable_ssl" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_SSL_CHECK
+ AC_MSG_CHECKING(SSL_LIBS=$SSL_LIBS)
+fi
+AC_SUBST(SSL_LIBS)
+
dnl SNMP Check
AC_ARG_ENABLE(snmp,
[ --enable-snmp use SNMP library, if available. [default=yes]],,enable_snmp=yes)
@@ -356,9 +368,9 @@ else
#
unset ac_cv_lib_snmp_sprint_objid
SNMP_LIBS="-lsnmp -lkstat"
- ],,$SOCKET_LIBS $NSL_LIBS -lkstat
+ ],,$SOCKET_LIBS $NSL_LIBS $SSL_LIBS -lkstat
)
- ], $SOCKET_LIBS $NSL_LIBS
+ ], $SOCKET_LIBS $NSL_LIBS $SSL_LIBS
)
fi