aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorsfisher <sfisher@f5534014-38df-0310-8fa8-9805f1628bb7>2008-04-04 23:37:31 +0000
committersfisher <sfisher@f5534014-38df-0310-8fa8-9805f1628bb7>2008-04-04 23:37:31 +0000
commitba74df830b2aebf82bded888973ad1a66636a4c6 (patch)
treeb684835b182981bde5cc19597397a86838a3b1a9 /configure.in
parentb90d444a16332f33846233b0ca105ab80c32c871 (diff)
Remove GTK1 from Unix build process.
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@24775 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 4 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index b9e85e7a52..44e14e62b4 100644
--- a/configure.in
+++ b/configure.in
@@ -507,12 +507,6 @@ AC_ARG_ENABLE(wireshark,
[build GTK+-based wireshark. @<:@default=yes, if GTK+ available@:>@]),
enable_wireshark=$enableval,enable_wireshark=yes)
-AC_ARG_ENABLE(gtk2,
- AC_HELP_STRING( [--disable-gtk2],
- [build Glib1/Gtk1+-based wireshark/tshark. @<:@default=no@:>@]),
- enable_gtk2=$enableval,enable_gtk2=yes)
-AM_CONDITIONAL(USE_GTK2, test x$enable_gtk2 = xyes)
-
AC_ARG_ENABLE(threads,
AC_HELP_STRING( [--enable-threads],
[use threads in wireshark. @<:@default=no@:>@]),
@@ -553,12 +547,8 @@ AC_DEFINE_UNQUOTED(DATAFILE_DIR,"$datafiledir", [Directory for data])
# We don't add $GLIB_LIBS to LIBS, because we don't want to force all
# programs to be built with GTK+.
#
-if test "x$enable_gtk2" = "xyes" -a "x$enable_wireshark" = "xyes"; then
- GTK_OK=two
+if test "x$enable_wireshark" = "xyes"; then
AM_PATH_GTK_2_0(2.0.0, CFLAGS="$CFLAGS $GTK_CFLAGS", GTK_OK=no, gthread)
-elif test "x$enable_gtk2" != "xyes" -a "x$enable_wireshark" = "xyes"; then
- GTK_OK=one
- AM_PATH_GTK(1.2.0, CFLAGS="$CFLAGS $GTK_CFLAGS", GTK_OK=no )
else
GTK_OK=no
fi
@@ -587,21 +577,14 @@ if test "$GTK_OK" = "no" ; then
wireshark_bin=""
wireshark_man=""
# Honor GLIB_CFLAGS
- if test "x$enable_gtk2" = "xyes" ; then
- AM_PATH_GLIB_2_0(2.0.0, CFLAGS="$CFLAGS $GLIB_CFLAGS", AC_MSG_ERROR(GLib2 distribution not found.), gmodule)
- else
- AM_PATH_GLIB(1.2.0, CFLAGS="$CFLAGS $GLIB_CFLAGS", AC_MSG_ERROR(GLib distribution not found.), gmodule)
- fi
+ AM_PATH_GLIB_2_0(2.0.0, CFLAGS="$CFLAGS $GLIB_CFLAGS", AC_MSG_ERROR(GLib2 distribution not found.), gmodule)
+
else
wireshark_bin="wireshark\$(EXEEXT)"
wireshark_man="wireshark.1"
wireshark_SUBDIRS="codecs gtk"
# Honor GLIB_CFLAGS
- if test "$GTK_OK" = "two" ; then
- AM_PATH_GLIB_2_0(2.0.0, , AC_MSG_ERROR(GLib distribution not found.), gmodule)
- else
- AM_PATH_GLIB(1.2.0, , AC_MSG_ERROR(GLib distribution not found.), gmodule)
- fi
+ AM_PATH_GLIB_2_0(2.0.0, , AC_MSG_ERROR(GLib distribution not found.), gmodule)
fi
#
@@ -1309,9 +1292,7 @@ AC_COMPILE_IFELSE(
AC_LANG_SOURCE(
[[
#include <glib.h>
- #if GTK_MAJOR_VERSION >= 2
#include <glib/gprintf.h>
- #endif
#include <stdio.h>
main()
@@ -1805,11 +1786,8 @@ echo " Install dumpcap setuid : $setuid_message"
echo " Use plugins : $have_plugins"
echo " Build lua plugin : $lua_message"
echo " Build rtp_player : $portaudio_message"
-echo " Use GTK+ v2 library : $enable_gtk2"
-if test "x$enable_gtk2" = "xyes" ; then
echo " Use threads : $enable_threads"
echo " Build profile binaries : $enable_profile_build"
-fi
echo " Use pcap library : $want_pcap"
echo " Use zlib library : $zlib_message"
echo " Use pcre library : $pcre_message"