aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorobiot <obiot@f5534014-38df-0310-8fa8-9805f1628bb7>2004-01-10 16:51:07 +0000
committerobiot <obiot@f5534014-38df-0310-8fa8-9805f1628bb7>2004-01-10 16:51:07 +0000
commit9276adc4b6d12ed0f70896fbee3a0160b7240d20 (patch)
tree409dc4421c330d1b31d3ec27e691cdcaa6eb8aa2 /configure.in
parent015faea6946434328399b46ffccc0b6b2ea5fa90 (diff)
Add -Wbad-function-cast to extra gcc flags.
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@9639 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b16f768fc4..fada00be1e 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.243 2004/01/10 16:34:27 obiot Exp $
+# $Id: configure.in,v 1.244 2004/01/10 16:50:52 obiot Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -78,7 +78,7 @@ AC_ARG_WITH(extra-gcc-checks,
[
if test $withval != no
then
- ethereal_extra_gcc_flags=" -Wcast-qual -Wcast-align -pedantic"
+ ethereal_extra_gcc_flags=" -Wcast-qual -Wcast-align -Wbad-function-cast -pedantic"
fi
],)
AC_MSG_CHECKING(to see if we can add '-Wall -W$ethereal_extra_gcc_flags' to CFLAGS)