aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2004-05-09 10:03:41 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2004-05-09 10:03:41 +0000
commit7b627e9908b35102db534323f22494f1bf96ba9e (patch)
tree96fab6287a112ff9379ebf012a7a939884b62ec1 /configure.in
parent6431bbd77fb1aeddb8a0245244d3ac29005e293d (diff)
From Lars Roland: add support for building a libethereal.dll with MSVC:
add a config.nmake option to control whether to build libethereal.dll or not; remove "./wiretap" from PATH to prevent problems due to wrongly-loaded files; build dissector.lib with MSVC; move "print.c" and "ps.c" to the dissector helpers, as "print.c" imports variables from packet-frame.c and packet-data.c, which are in libethereal; move "g711.c" out of the dissector helpers, as they're used only by Ethereal in a tap, not in Tethereal or in any dissector; add a .def file for libethereal; arrange to declare global variables exported from libethereal with "__declspec(dllimport)" when building programs that import those variables; update the NSIS installer. Make the "configure" script define ETH_VAR_IMPORT as "extern". git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@10834 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 21362b3ecc..89ff0a454f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.257 2004/04/25 21:07:15 obiot Exp $
+# $Id: configure.in,v 1.258 2004/05/09 10:03:36 guy Exp $
#
AC_INIT(etypes.h)
@@ -766,6 +766,12 @@ else
fi
AC_SUBST(ADNS_LIBS)
+#
+# Define ETH_VAR_IMPORT appropriately for declarations of external
+# variables exported from dynamically-linked libraries.
+#
+AC_DEFINE(ETH_VAR_IMPORT, extern, [Define as the string to precede external variable declarations in dynamically-linked libraries])
+
dnl Checks for typedefs, structures, and compiler characteristics.
# AC_C_CONST