aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2004-08-22 01:41:47 +0000
committerguy <guy@f5534014-38df-0310-8fa8-9805f1628bb7>2004-08-22 01:41:47 +0000
commit7277e8f90f083baf42dab535fbd751b4bde9eba6 (patch)
tree6fa7e8bdbb73d55f84194fc16d6e150982a78395 /configure.in
parent4def55dac4c668f512715d7fdf318bdd89fa8910 (diff)
FreeBSD 3.4 doesn't have "strtoull()", but it does have "strtouq()",
which does the same thing - check for "strtoull()" and, if it's missing, check for "strtouq()" and, if we have it, define strtoull as strtouq. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@11798 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 23e63d1340..88a14ba9fb 100644
--- a/configure.in
+++ b/configure.in
@@ -468,6 +468,24 @@ else
])
fi
+AC_CHECK_FUNC(strtoull,,
+ [
+ #
+ # No strtoull - do we have strtouq?
+ #
+ AC_CHECK_FUNC(strtouq,
+ [
+ #
+ # Yes - define strtoull to be strtouq.
+ #
+ AC_DEFINE(strtoull, strtouq,
+ [Define as a function that behaves like strtoull])
+ ],
+ [
+ AC_MSG_ERROR([This platform has neither strtoull nor strtouq.])
+ ])
+ ])
+
AC_SUBST(ethereal_bin)
AC_SUBST(ethereal_man)