aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorgerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2004-06-22 15:18:45 +0000
committergerald <gerald@f5534014-38df-0310-8fa8-9805f1628bb7>2004-06-22 15:18:45 +0000
commit438ba04ae4e4eb7d43a547dbd1e06372c4a22d7a (patch)
tree38eb04084868b24ff2c467ad9f0f198f1330be02 /configure.in
parent65a6344d9e0a31e0dfeb44510d3e0f493ba6a717 (diff)
Handle cases where PRI[doxu]64 is defined, but u_int64_t isn't. (Solaris 8
only defines uint64_t, for example). git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@11212 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7fddf462a2..3a72fee21a 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.269 2004/06/22 00:40:02 guy Exp $
+# $Id: configure.in,v 1.270 2004/06/22 15:18:45 gerald Exp $
#
AC_INIT(etypes.h)
@@ -263,6 +263,12 @@ fi
# We can't just check for <inttypes.h> - some systems have one that
# doesn't define all the PRI[doxu]64 macros.
#
+AC_CHECK_TYPE(
+ uint64_t,
+ ac_ethereal_uint64_t_type=uint64_t,
+ ac_ethereal_uint64_t_type=u_int_64_t
+)
+
AC_CHECK_HEADERS(inttypes.h,
[
#
@@ -279,10 +285,10 @@ AC_CHECK_HEADERS(inttypes.h,
main()
{
- printf("%" PRId64 "\n", (u_int64_t)1);
- printf("%" PRIo64 "\n", (u_int64_t)1);
- printf("%" PRIx64 "\n", (u_int64_t)1);
- printf("%" PRIu64 "\n", (u_int64_t)1);
+ printf("%" PRId64 "\n", ($ac_ethereal_uint64_t_type)1);
+ printf("%" PRIo64 "\n", ($ac_ethereal_uint64_t_type)1);
+ printf("%" PRIx64 "\n", ($ac_ethereal_uint64_t_type)1);
+ printf("%" PRIu64 "\n", ($ac_ethereal_uint64_t_type)1);
}
]])
],