aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorlego <lego@f5534014-38df-0310-8fa8-9805f1628bb7>2007-08-25 20:27:58 +0000
committerlego <lego@f5534014-38df-0310-8fa8-9805f1628bb7>2007-08-25 20:27:58 +0000
commit3d3151d0b6799c152d3ab73cea5023e7fd8d37fd (patch)
tree7b0a724f5af02559801332f4140cb361baeb796e /configure.in
parent5feddcca1610cf3c27c9e7d0247ca7d66d799b2d (diff)
get libsmi into the picture
git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@22661 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9d8aee5a93..160c909068 100644
--- a/configure.in
+++ b/configure.in
@@ -116,13 +116,24 @@ if test "x$with_gcrypt" = "xyes"; then
if test x$libgcrypt_config_prefix != x ; then
AC_MSG_ERROR([[libgcrypt not found; install libgcrypt-devel package for your system]])
else
- echo echo "libgcrypt not found, disabling ipsec decryption"
+ echo "libgcrypt not found, disabling ipsec decryption"
gcrypt_message="no"
fi
]
)
fi
+# libsmi
+libsmi_message="no"
+AC_ARG_WITH([libsmi],
+ AC_HELP_STRING( [--with-libsmi=@<:@yes/no@:>@],
+ [use smi library @<:@default=yes@:>@]),
+ with_libsmi="$withval", with_libsmi="yes")
+if test "x$with_libsmi" = "xyes"; then
+ AM_PATH_LIBSMI
+ AM_CONDITIONAL(HAVE_SMI, "x$with_libsmi" = "xyes")
+fi
+
# Check for xsltproc
AC_PATH_PROG(XSLTPROC, xsltproc)
AC_CHECK_PROG(HAVE_XSLTPROC, xsltproc, "yes", "no")
@@ -1635,6 +1646,7 @@ echo " Use zlib library : $zlib_message"
echo " Use pcre library : $pcre_message"
echo " Use kerberos library : $krb5_message"
echo " Use GNU ADNS library : $adns_message"
+echo " Use SMI SNMP library : $libsmi"
echo " Use GNU crypto library : $gcrypt_message"
echo " Use SSL crypto library : $ssl_message"
echo " Use IPv6 name resolution : $enable_ipv6"