aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2003-01-09 23:50:55 +0000
committerGuy Harris <guy@alum.mit.edu>2003-01-09 23:50:55 +0000
commit9e144356f8e8d826d58407e3ec6a061813766e34 (patch)
tree46f5774b0344a0a26fa9ca024c0d198ab2e0ef5e /configure.in
parent2f10d65eb2cd592625d877f737d9991a107999dd (diff)
Use "plugindir", not "PLUGIN_DIR", as the variable name in the configure
script for the plugin directory; in most Makefile.am files it's set with plugindir = @plugindir@ (along the lines of what's done with other variables with pathnames - the variable name is all lower case), so the variable needs to be named "plugindir". Fix the DOCSIS plugins' Makefile.am to use "plugindir". Don't bother doing "AC_SUBST(PLUGIN_DIR)", as no Makefiles use PLUGIN_DIR as an autoconf variable. svn path=/trunk/; revision=6887
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index f285641102..cc24c9a168 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.189 2002/12/04 04:26:12 gerald Exp $
+# $Id: configure.in,v 1.190 2003/01/09 23:50:52 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -701,7 +701,6 @@ dnl check whether plugins should be enabled and, if they should be,
dnl check for plugins directory - stolen from Amanda's configure.in
dnl
plugindir="$libdir/ethereal/plugins/$VERSION"
-PLUGIN_DIR="$plugindir"
AC_ARG_WITH(plugins,
[ --with-plugins[=DIR] support plugins (installed in DIR, if supplied).],
[
@@ -720,7 +719,7 @@ AC_ARG_WITH(plugins,
then
AC_MSG_ERROR([GLib on this platform doesn't support loadable modules, so you can't enable plugins.])
fi
- PLUGIN_DIR="$withval"
+ plugindir="$withval"
;;
esac
]
@@ -730,16 +729,15 @@ AM_CONDITIONAL(HAVE_PLUGINS, test x$have_plugins = xyes)
if test x$have_plugins = xyes
then
AC_DEFINE(HAVE_PLUGINS)
- PLUGIN_DIR=`(
+ plugindir=`(
test "x$prefix" = xNONE && prefix=$ac_default_prefix
test "x$exec_prefix" = xNONE && exec_prefix=${prefix}
- eval echo "$PLUGIN_DIR"
+ eval echo "$plugindir"
)`
- AC_DEFINE_UNQUOTED(PLUGIN_DIR,"$PLUGIN_DIR", [Plugin installation directory])
+ AC_DEFINE_UNQUOTED(PLUGIN_DIR, "$plugindir", [Plugin installation directory])
else
- AC_DEFINE(PLUGIN_DIR,NULL)
+ AC_DEFINE(PLUGIN_DIR, NULL)
fi
-AC_SUBST(PLUGIN_DIR)
AC_SUBST(plugindir)
dnl libtool defs