aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss@ulticom.com>2012-03-27 15:15:52 +0000
committerJeff Morriss <jeff.morriss@ulticom.com>2012-03-27 15:15:52 +0000
commit989057bb09f042db7c740802987f406d7fccfc0b (patch)
tree04c59d9a6ec0ee199472d1e5105552e5b3f840b8 /configure.in
parentc77146cc0d8936570c57cbd91934661a9d683036 (diff)
Don't enable airpcap if we don't HAVE_LIBPCAP.
svn path=/trunk/; revision=41799
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 20 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index cb09a4dc12..d836c64989 100644
--- a/configure.in
+++ b/configure.in
@@ -1225,7 +1225,26 @@ else
AC_WIRESHARK_PCAP_CHECK
fi
-# Enable/disable dumpcap
+
+dnl Check for airpcap
+AC_MSG_CHECKING(whether to include airpcap support)
+AC_ARG_ENABLE(airpcap,
+ AC_HELP_STRING( [--enable-airpcap],
+ [use AirPcap in Wireshark @<:@default=yes@:>@]),
+ enable_airpcap=$enableval, enable_airpcap=yes)
+
+if test x$enable_airpcap = xyes; then
+ if test "x$want_pcap" = "xno" ; then
+ enable_airpcap=no
+ AC_MSG_RESULT(pcap not available - disabling airpcap)
+ else
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_AIRPCAP, 1, [Enable AirPcap])
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+
dnl dumpcap check
AC_MSG_CHECKING(whether to build dumpcap)
@@ -1730,21 +1749,6 @@ AC_DEFINE(WS_VAR_IMPORT, extern, [Define as the string to precede external varia
#
AC_DEFINE(WS_MSVC_NORETURN,, [Define as the string to precede declarations of routines that never return])
-AC_ARG_ENABLE(airpcap,
-[
- AC_HELP_STRING( [--enable-airpcap],
- [use AirPcap in Wireshark @<:@default=yes@:>@])
-],[
- enable_airpcap=$enableval
- if test x$enable_airpcap != xno; then
- AC_DEFINE(HAVE_AIRPCAP, 1, [Enable AirPcap])
- fi
-],[
- enable_airpcap=yes
- AC_DEFINE(HAVE_AIRPCAP, 1, [Enable AirPcap])
-]
-)
-
dnl Checks for typedefs, structures, and compiler characteristics.
# AC_C_CONST