aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBill Meier <wmeier@newsguy.com>2011-08-02 16:17:25 +0000
committerBill Meier <wmeier@newsguy.com>2011-08-02 16:17:25 +0000
commit6e97a2e1431022d0c5dabdf61762a425944c3f12 (patch)
tree509500a1de7181a29ce2f2c875332f31d318ff5b /configure.in
parent9363362f5fbf182df3d774b4848e763dd214ef96 (diff)
For now: treat GCC 4.6 'unused-but-set' reports as just warnings (i.e., when -Werror).
GCC 4.6 has added 'unused but set' reports so this change allows builds to proceed without erroring out for those building from SVN with GCC 4.6. (AFAIK Wireshark source distributions do not enable -Werror). This change can be removed (at least globally) once the code as been fixed. svn path=/trunk/; revision=38311
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3c880361cc..72264ee030 100644
--- a/configure.in
+++ b/configure.in
@@ -370,7 +370,8 @@ AC_WIRESHARK_GCC_CFLAGS_CHECK(-Warray-bounds)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wcast-align)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wformat-security)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wold-style-definition)
-
+AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-error=unused-but-set-variable) ## for now
+AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-error=unused-but-set-parameter) ## for now
#
# Use the faster pre gcc 4.5 floating point precision if available;
# clang doesn't error out on -f options that it doesn't know about,