aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2003-05-04 18:50:56 +0000
committerGerald Combs <gerald@wireshark.org>2003-05-04 18:50:56 +0000
commit1d9b54fc072952758813d6cbce25bbe1ef8c2ac3 (patch)
tree1fc6bf8e2065199f49398fdfb4c3ef23ac1ab398 /configure.in
parent5cc92eeb86806e56d7524c4887716b688fbdd0ca (diff)
Add support for asynchronous DNS updates using the GNU ADNS library.
Support can be enabled at configure time by using "--with-adns=DIR". If support is enabled, async queries happen whenever host name resolution is enabled. Do we need a separate preference for async queries? Currently, only IPv4 reverse queries are supported. I can add IPv4 forward lookup support, but I don't have any way to test IPv6 queries. svn path=/trunk/; revision=7640
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c632db26da..d0082fa09c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.205 2003/05/01 03:09:51 gerald Exp $
+# $Id: configure.in,v 1.206 2003/05/04 18:50:51 gerald Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -617,6 +617,17 @@ fi
AC_SUBST(SNMP_LIBS)
+dnl ADNS Check
+ADNS_LIBS=''
+AC_MSG_CHECKING(whether to use the GNU ADNS library if available)
+if test "x$enable_adns" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_ADNS_CHECK
+fi
+AC_SUBST(ADNS_LIBS)
+
dnl Checks for typedefs, structures, and compiler characteristics.
# AC_C_CONST
@@ -791,6 +802,12 @@ else
zlib_message="yes"
fi
+if test "x$want_adns" = "xno" ; then
+ adns_message="no"
+else
+ adns_message="yes"
+fi
+
if test "x$NETSNMPCONFIG" != "xno" -a "x$NETSNMPCONFIG" != "x" -a -x "$NETSNMPCONFIG" ; then
snmp_libs_message="yes (net-snmp)"
elif test "x$SNMP_LIBS" = "x" ; then
@@ -815,5 +832,6 @@ echo " Use plugins : $have_plugins"
echo " Use GTK+ v2 library : $enable_gtk2"
echo " Use pcap library : $want_pcap"
echo " Use zlib library : $zlib_message"
+echo " Use GNU ADNS library : $adns_message"
echo " Use IPv6 name resolution : $enable_ipv6"
echo " Use UCD SNMP/NET-SNMP library : $snmp_libs_message"