aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2003-09-05 07:44:50 +0000
committerJörg Mayer <jmayer@loplof.de>2003-09-05 07:44:50 +0000
commit10b364c56dea8b351fd7150b17ec5786f441cff6 (patch)
tree83c4bb27a5beba5fee61ceab8bf6cb07cfcfaba4 /configure.in
parentdd2080a64633a1fd43644061c0a5dacc336a437e (diff)
- Make --enable-static work again (configure.in, Makefile.am)
- get rid of ...-static.o files in the build process (now done via config.h instead of compiler flag) - make packet-rtnet link statically (remove one unused function, rename another one) svn path=/trunk/; revision=8389
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6869a1f899..2694fbf530 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.218 2003/08/29 04:20:22 sharpe Exp $
+# $Id: configure.in,v 1.219 2003/09/05 07:44:44 jmayer Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -777,7 +777,13 @@ dnl libtool defs
AM_PROG_LIBTOOL
AC_SUBST(LIBTOOL_DEPS)
-AM_CONDITIONAL(ENABLE_STATIC, test x$enable_shared = xno)
+AM_CONDITIONAL(ENABLE_STATIC, test x$enable_static = xyes)
+if test x$enable_static = xyes -a x$have_plugins = xyes
+then
+ AC_DEFINE(ENABLE_STATIC, 1, [Link plugins statically into Ethereal])
+fi
+AC_SUBST(ENABLE_STATIC)
+
AM_CONFIG_HEADER(config.h)
AC_CONFIG_SUBDIRS(epan wiretap)
AC_OUTPUT(