aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2007-12-17 23:38:09 +0000
committerJörg Mayer <jmayer@loplof.de>2007-12-17 23:38:09 +0000
commit8060e871dce240cef8b5534be5241023135b6330 (patch)
tree3d007ed2a4454c51fcdd17f8cf52dc8b37f8d7bd /configure.in
parentd05b2361440888312d7343d8cd2eb5f0dbb45910 (diff)
Actually fail if no lex and yacc (derivatives) could be found.
Add -Wextra to extra warnings if supported. svn path=/trunk/; revision=23906
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e9a3f40697..5fceab39b9 100644
--- a/configure.in
+++ b/configure.in
@@ -25,9 +25,19 @@ dnl Work around libtool bug (fixed in the version 1.5a?)
AC_DEFUN([AC_PROVIDE_AC_LIBTOOL_DLOPEN], )
AC_LIBTOOL_DLOPEN
AC_PROG_LIBTOOL
+AC_PATH_PROG(PERL, perl)
AC_PROG_YACC
+AC_PATH_PROG(YACCDUMMY, $YACC)
+if test "x$YACCDUMMY" = x
+then
+ AC_MSG_ERROR(I couldn't find yacc (or bison or ...); make sure it's installed and in your path)
+fi
AM_PROG_LEX
-AC_PATH_PROG(PERL, perl)
+AC_PATH_PROG(LEXDUMMY, $LEX)
+if test "x$LEXDUMMY" = x
+then
+ AC_MSG_ERROR(I couldn't find (f)lex; make sure it's installed and in your path)
+fi
AC_PATH_PROG(POD2MAN, pod2man)
if test "x$POD2MAN" = x
then
@@ -182,6 +192,7 @@ AC_ARG_ENABLE(extra-gcc-checks,
if test $enableval != no
then
AC_WIRESHARK_GCC_CFLAGS_CHECK(-pedantic)
+ AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wextra)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-long-long)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wbad-function-cast)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wcast-qual)