aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSebastien Tandel <sebastien@tandel.be>2007-06-18 03:03:54 +0000
committerSebastien Tandel <sebastien@tandel.be>2007-06-18 03:03:54 +0000
commitadebfe60f13dbaff524f9ec676d011a4ebb349f7 (patch)
tree3f3b168fe8e59d51444b43eb85e3e485cc26ce90 /configure.in
parentd3b8c062ea7360780c828f36066602d0013a9262 (diff)
Fix bug #1395
Configure options '--with-libgnutls-prefix' and '--with-libgcrypt-prefix' could be used to indicate the path where the respective libraries had been installed. However, these options could not be used to compile wireshark without the use of them if installed on the system. These two macros are not part of the wireshark project. configure.in has therefore been modified so that wireshark can be compiled without gnutls or gcrypt. Two configure options have been introduced : '--with-gnutls' and '--with-gcrypt'. They take precedence on their 'prefix-specification' counterpart or in other words, if '-with-gnutls=no' and '--with-libgnutls-prefix' are used, wireshark will be compiled *without* gnutls. svn path=/trunk/; revision=22127
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a5999b7f3d..5dc8f49e97 100644
--- a/configure.in
+++ b/configure.in
@@ -76,7 +76,13 @@ AC_CHECK_PROG(HAVE_DOXYGEN, doxygen, "yes", "no")
AM_CONDITIONAL(HAVE_DOXYGEN, test x$HAVE_DOXYGEN = xyes)
# gnu tls
-AM_PATH_LIBGNUTLS(1.0.0,
+tls_message="no"
+AC_ARG_WITH([gnutls],
+ AC_HELP_STRING( [--with-gnutls=@<:@yes/no@:>@],
+ [use gnutls library @<:@default=yes@:>@]),
+ with_gnutls="$withval", with_gnutls="yes")
+if test "x$with_gnutls" = "xyes"; then
+ AM_PATH_LIBGNUTLS(1.0.0,
[
echo "gnuTLS found, enabling ssl decryption"
AC_DEFINE(HAVE_LIBGNUTLS, 1, [Define to use gnutls library])
@@ -90,10 +96,17 @@ AM_PATH_LIBGNUTLS(1.0.0,
tls_message="no"
fi
]
-)
+ )
+fi
# libgrypt
-AM_PATH_LIBGCRYPT(1.1.42,
+gcrypt_message="no"
+AC_ARG_WITH([gcrypt],
+ AC_HELP_STRING( [--with-gcrypt=@<:@yes/no@:>@],
+ [use gcrypt library @<:@default=yes@:>@]),
+ with_gcrypt="$withval", with_gcrypt="no")
+if test "x$with_gcrypt" = "xyes"; then
+ AM_PATH_LIBGCRYPT(1.1.42,
[
echo "libgcrypt found, enabling ipsec decryption"
AC_DEFINE(HAVE_LIBGCRYPT, 1, [Define to use libgcrypt])
@@ -107,7 +120,8 @@ AM_PATH_LIBGCRYPT(1.1.42,
gcrypt_message="no"
fi
]
-)
+ )
+fi
# Check for xsltproc
AC_PATH_PROG(XSLTPROC, xsltproc)