aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2009-04-21 16:57:52 +0000
committerGuy Harris <guy@alum.mit.edu>2009-04-21 16:57:52 +0000
commit54c159cb41d3d885807ce117b41cfbb444e45e5a (patch)
tree26c23c6b5773084609cd0d8ff02dfbd9cf624e1f /configure.in
parent85f8b0d87d42dd092ee8baaa0786d9ef8cf49080 (diff)
Turn on -Wshorten-64-to-32 by default, and fix some issues that turned
up (99 44/100% of which were assignments of double-precision floating-point constants to floats). Hopefully this will catch at least some P64 issues on UN*X. svn path=/trunk/; revision=28108
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index f31aa0ee50..a757ebf0a6 100644
--- a/configure.in
+++ b/configure.in
@@ -241,12 +241,8 @@ AC_ARG_ENABLE(extra-gcc-checks,
# for now.
#
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wwrite-strings)
- AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wshorten-64-to-32)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wstrict-prototypes)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wmissing-declarations)
- #Temporarily put cast-align here waiting eradication of 'cast
- #increases required alignment of target type' on the Solaris
- #slave.
#
# epan/dissectors/packet-afs.c blocks this one for now.
#
@@ -261,6 +257,7 @@ AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-pointer-sign)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Warray-bounds)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wcast-align)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wformat-security)
+AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wshorten-64-to-32)
#
# If we're running gcc add '-D_U_="__attribute__((unused))"' to CFLAGS as well,