aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-02-22 17:52:06 +0000
committerGerald Combs <gerald@wireshark.org>2008-02-22 17:52:06 +0000
commit28394977662db1032b0fa9aadc3ffb7c946c9640 (patch)
treea515b0d563fec97707e2c97f8db6e29b528ba427 /configure.in
parent3ebc2a4d004da00b764d390bc15299edb2de9217 (diff)
Rawshark depends on libpcap. Make sure we enforce this in the configure
script, just as we do with dumpcap. svn path=/trunk/; revision=24422
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in49
1 files changed, 32 insertions, 17 deletions
diff --git a/configure.in b/configure.in
index 5aa1ac545b..3cf2b8855e 100644
--- a/configure.in
+++ b/configure.in
@@ -829,23 +829,6 @@ else
fi
AC_SUBST(randpkt_bin)
-# Enable/disable rawshark
-
-AC_ARG_ENABLE(rawshark,
- AC_HELP_STRING( [--enable-rawshark],
- [build rawshark. @<:@default=yes@:>@]),
- rawshark=$enableval,enable_rawshark=yes)
-
-if test "x$enable_rawshark" = "xyes" ; then
- rawshark_bin="rawshark\$(EXEEXT)"
- rawshark_man="rawshark.1"
-else
- rawshark_bin=""
- rawshark_man=""
-fi
-AC_SUBST(rawshark_bin)
-AC_SUBST(rawshark_man)
-
dnl Checks for "gethostbyname()" - and "-lnsl", if we need it to get
@@ -915,6 +898,38 @@ fi
AC_SUBST(dumpcap_bin)
AC_SUBST(dumpcap_man)
+# Enable/disable rawshark
+
+dnl rawshark check
+AC_MSG_CHECKING(whether to build rawshark)
+
+AC_ARG_ENABLE(rawshark,
+ AC_HELP_STRING( [--enable-rawshark],
+ [build rawshark. @<:@default=yes@:>@]),
+ rawshark=$enableval,enable_rawshark=yes)
+
+if test "x$enable_rawshark" = "xyes" ; then
+ if test "x$want_pcap" = "xno" ; then
+ enable_rawshark=no
+ AC_MSG_RESULT(pcap not available - disabling rawshark)
+ else
+ AC_MSG_RESULT(yes)
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
+
+if test "x$enable_rawshark" = "xyes" ; then
+ rawshark_bin="rawshark\$(EXEEXT)"
+ rawshark_man="rawshark.1"
+else
+ rawshark_bin=""
+ rawshark_man=""
+fi
+AC_SUBST(rawshark_bin)
+AC_SUBST(rawshark_man)
+
+
dnl pcap remote check
AC_MSG_CHECKING(whether to use libpcap remote capturing feature)