aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2008-10-27 04:50:57 +0000
committerGerald Combs <gerald@wireshark.org>2008-10-27 04:50:57 +0000
commit1b7064bb6a8176e979595c3a0e5d9b96778b4fc8 (patch)
treeb4ba1971ac1b9ea228540dd609718d57fd5b7b62 /configure.in
parent09bf9e694629b37f201467b988589573f5c3acf9 (diff)
Add support for the GeoIP library. Using different database files,
GeoIP can map IP addresses to Countries, Cities, AS numbers, ISPs, etc. If any library paths are defined AND any database files are found, corresponding columns are added to the endpoint tables in the GUI. To do: - Add columns to the conversation list - Add GeoIP info to "-z conv,..." - Create a default UAT file. svn path=/trunk/; revision=26571
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 9a432a6b03..8c44d5b171 100644
--- a/configure.in
+++ b/configure.in
@@ -1293,6 +1293,31 @@ else
fi
AC_SUBST(ADNS_LIBS)
+dnl GEOIP Check
+GEOIP_LIBS=''
+AC_MSG_CHECKING(whether to use the GeoIP IP address mapping library if available)
+
+AC_ARG_WITH(geoip,
+ AC_HELP_STRING( [--with-geoip@<:@=DIR@:>@],
+ [use GeoIP (located in directory DIR, if supplied). @<:@default=yes, if present@:>@]),
+[
+if test "x$withval" = "xno"; then
+ want_geoip=no
+elif test "x$withval" = "xyes"; then
+ want_geoip=yes
+elif test -d "$withval"; then
+ want_geoip=yes
+ AC_WIRESHARK_ADD_DASH_L(LDFLAGS, ${withval}/lib)
+fi
+])
+if test "x$want_geoip" = "xno"; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_WIRESHARK_GEOIP_CHECK
+fi
+AC_SUBST(GEOIP_LIBS)
+
#
# Define WS_VAR_IMPORT appropriately for declarations of external
# variables exported from dynamically-linked libraries.