aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGilbert Ramirez <gram@alumni.rice.edu>2000-01-10 17:33:17 +0000
committerGilbert Ramirez <gram@alumni.rice.edu>2000-01-10 17:33:17 +0000
commit1990d5fb5ca844ef3c09bb0b177f3bc1ced3d924 (patch)
tree413b147e552443eae7de52faa7c999543babae13 /configure.in
parent9fe38ca2b5dc37b9f47ea3f047a0b079b47c4459 (diff)
Some initial changes for win32 support, but not all.
Added lots of #ifdef HAVE_*_H wrappers. Added some #defines in config.h.win32 Check for more headers in configure.in Added prototype for inet_aton() in inet_v6defs.h. Changed "BYTE" token (i.e., #define) in ascend-gramamr.y because it conflicts with a windows definition. Use HEXBYTE instead. svn path=/trunk/; revision=1448
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4bcf0f4c24..b3a7dc0577 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.71 2000/01/09 20:05:37 guy Exp $
+# $Id: configure.in,v 1.72 2000/01/10 17:32:50 gram Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -154,10 +154,12 @@ fi
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(fcntl.h sys/ioctl.h sys/time.h unistd.h stdarg.h netdb.h)
-AC_CHECK_HEADERS(sys/stat.h sys/sockio.h sys/types.h netinet/in.h sys/socket.h net/if.h)
-AC_CHECK_HEADERS(sys/wait.h)
+AC_CHECK_HEADERS(sys/stat.h sys/sockio.h sys/types.h sys/socket.h)
+AC_CHECK_HEADERS(sys/wait.h sys/param.h)
+AC_CHECK_HEADERS(netinet/in.h net/if.h)
AC_CHECK_HEADERS(stddef.h)
AC_CHECK_HEADERS(dlfcn.h)
+AC_CHECK_HEADERS(arpa/inet.h arpa/nameser.h)
dnl SNMP Check
AC_ARG_ENABLE(snmp,