aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2012-12-09 04:00:03 +0000
committerGuy Harris <guy@alum.mit.edu>2012-12-09 04:00:03 +0000
commit8d7e398dc74ca2e14920cff4423369cbe7a93093 (patch)
tree55004b277a2eb9ef459298fea3f9e984e56b9d5e /configure.ac
parentb961881fb35d6d678daeb82fdf51e625b90c206b (diff)
Force -Wshadow on - it wasn't included on the Ubuntu buildbot, so I want
to see whether it really doesn't work right (i.e., warns bogusly about variables in prototype definitions of function pointers shadowing variables) or if the test fails for some other reason. svn path=/trunk/; revision=46476
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 508d295ebc..e6278d32e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -435,19 +435,7 @@ AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wold-style-definition, C)
# some Xcode versions that came with Mac OS X 10.5) complain about
# that.
#
-AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wshadow, C,
- [
-extern int atoi(char *p);
-
-int
-foo(char *p)
-{
- int (*fptr)(char *p) = atoi;
-
- return fptr(p) * 2;
-}
- ],
- [warns about variables in function declarations shadowing other variables])
+AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wshadow, C)
AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-error=unused-but-set-variable) ## for now
#
# Use the faster pre gcc 4.5 floating point precision if available;