aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-06-28 12:18:03 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-06-28 12:18:03 +0000
commit8c826964bf6738e3d1bcc58a4118e1bbee56162f (patch)
tree8b4683d9a69af25d354c8302a8517f4cbc18d6c8 /configure.ac
parent9a09ef907a17b00eb9a7b268f437f70387f4d514 (diff)
Standard C++ header files don't have .h in their name: #include <iostream>
rather than #include <iostream.h>. Also reference cout as std::cout in the test program. svn path=/trunk/; revision=50206
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f81854c4db..67b6123636 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1078,16 +1078,16 @@ if test "x$enable_wireshark" = "xyes"; then
# the C++ compiler.
#
# So we check by feeding the purported C++ compiler a
- # program using C++ features (iostream.h).
+ # program using C++ features (iostream).
#
AC_MSG_CHECKING(whether we have a working C++ compiler)
AC_LANG_PUSH([C++])
AC_LINK_IFELSE([AC_LANG_PROGRAM(
[
-#include <iostream.h>
+#include <iostream>
],
[
- cout << "Hello World! ";
+ std::cout << "Hello World! ";
return 0;
])],
[AC_MSG_RESULT(yes)],