aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-02-03 21:39:11 +0000
committerGuy Harris <guy@alum.mit.edu>2013-02-03 21:39:11 +0000
commit02da11d6451fc7ba9fa7cdeb0fe4c341a8a9ccb5 (patch)
tree3db3ed4ca1d2d48bd19057407ed0ce673bd92d45 /configure.ac
parentb85efceddc52eaffd219702f97b8c23755baabf3 (diff)
Sigh. At least on my Fedora 16 with KDE, the Qt 4 versions of uic and
moc are called uic-qt4 and moc-qt4. Look for them by names, plural. svn path=/trunk/; revision=47457
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d76a5f2d5..cfea971d62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -960,6 +960,35 @@ if test "x$enable_wireshark" = "xyes"; then
AC_MSG_NOTICE([QtPrintSupport not found. Assuming Qt4]))
#
+ # OK, maybe uic is called uic, or maybe it's called
+ # uic-qt4 (yay, Fedora 16).
+ #
+ AC_PATH_PROG(UIC, uic)
+ if test "x$UIC" = x
+ then
+ AC_PATH_PROG(UIC, uic-qt4)
+ if test "x$UIC" = x
+ then
+ AC_MSG_ERROR(I couldn't find uic or uic-qt4; make sure it's installed and in your path)
+ fi
+ fi
+ AC_SUBST(UIC)
+
+ #
+ # And the same applies to moc.
+ #
+ AC_PATH_PROG(MOC, moc)
+ if test "x$MOC" = x
+ then
+ AC_PATH_PROG(MOC, moc-qt4)
+ if test "x$MOC" = x
+ then
+ AC_MSG_ERROR(I couldn't find moc or moc-qt4; make sure it's installed and in your path)
+ fi
+ fi
+ AC_SUBST(MOC)
+
+ #
# We don't know whether we have GTK+, but we
# won't be using it, so it's as if we don't
# have it.