aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2015-10-14 20:23:46 +0200
committerPeter Wu <peter@lekensteyn.nl>2015-10-25 14:05:07 +0000
commitfe1ab42f160ac9b67f181775321fa89b62102159 (patch)
tree2fd6e026c1af45a177a01adfcd5dbd3d3d17a9b3 /configure.ac
parent2ddd92b6f8f587325b9e14598658626f3a007c5c (diff)
Require GnuTLS 2.12.0, add cmake version detection
Since v2.1.0rc0-17-g877fd03 and v2.0.0rc0-23-g263ff53 ("ssl-utils: load RSA keys based on their modulus+exponent"), GnuTLS 2.12.0 is needed. Add a version check to cmake as well, tested on CentOS6 (with pkg-config check disabled to verify the code path). Note that RHEL6 has GnuTLS 2.8.5 and thus SSL decryption with a RSA private key is no longer supported on that version. Change-Id: I99fdfe6790107f48629dd435794fe8880263063d Reviewed-on: https://code.wireshark.org/review/11044 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michal Labedzki <michal.labedzki@tieto.com> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f086f53d35..c0539de51b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -578,8 +578,8 @@ if test "x$with_gnutls" = "xyes"; then
)
if test "x$have_license_compatible_gnutls" != "xyes"; then
- PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.2.0 gnutls < 3],
- [ have_license_compatible_gnutls="yes" ] , [ echo "GnuTLS >= 1.2.0, < 3.0 not found " ]
+ PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 2.12.0 gnutls < 3],
+ [ have_license_compatible_gnutls="yes" ] , [ echo "GnuTLS >= 2.12.0, < 3.0 not found " ]
)
fi