aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-07-09 21:09:48 -0700
committerGuy Harris <guy@alum.mit.edu>2015-07-10 21:30:33 +0000
commita1a2d50716ae3c1fb882726c82e98815faca2b27 (patch)
treeed0414e97c48012607c1725016f18cbe8d460cc1 /configure.ac
parenta63f841fec2a7c0dd3d42f24a85fde0b447ee790 (diff)
Make .o files, not .cpp and .h files, depend on the ui_*.h files.
That's one of the mechanisms the autotools documentation suggests using to handle generated header files. Using it means that "make dist" will no longer try to build those files (they're not part of the distribution - and they can't be, as the files would be different for Qt 4 and Qt 5, and need to be generated by the uic from the same version of Qt as the one against which Wireshark is being built). This means we don't need to try to find uic, moc, or rcc if we're not building with Qt, so don't do so. Change-Id: Id2aadb8289598b82e14e4ed402ff8cdc15fdef74 Reviewed-on: https://code.wireshark.org/review/9583 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 16 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 01d5feeca5..f59b742990 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1650,6 +1650,22 @@ if test "x$enable_wireshark" = "xyes"; then
# compile.
#
CPPFLAGS="-DQT_GUI_LIB"
+
+ #
+ # We're building with Qt, so we need the Qt build
+ # tools in order to build the Wireshark GUI.
+ # We've found a particular major version of Qt,
+ # and we want that version's build tools; for
+ # example, the Qt 4 version of uic produces files
+ # that include Qt headers with paths that work
+ # with Qt 4 but not Qt 5, so we can't use the
+ # Qt 4 version of uic if we're building with Qt 5.
+ AC_WIRESHARK_QT_TOOL_CHECK(UIC, uic, "$qt_version")
+ AC_SUBST(UIC)
+ AC_WIRESHARK_QT_TOOL_CHECK(MOC, moc, "$qt_version")
+ AC_SUBST(MOC)
+ AC_WIRESHARK_QT_TOOL_CHECK(RCC, rcc, "$qt_version")
+ AC_SUBST(RCC)
],
[
case "$with_qt" in
@@ -1823,33 +1839,6 @@ else
AM_PATH_GLIB_2_0($GLIB_MIN_VERSION, , AC_MSG_ERROR(GLib $GLIB_MIN_VERSION or later distribution not found.), gthread gmodule)
fi
-#
-# If we're building with Qt, we need the Qt build tools in order to
-# build the Wireshark GUI. We've already found Qt, and found a
-# particular major version, and we want that version's build tools;
-# for example, the Qt 4 version of uic produces files that include
-# Qt headers with paths that work with Qt 4 but not Qt 5, so we can't
-# use the Qt 4 version of uic if we're building with Qt 5.
-#
-# If we're *not* building with Qt, "make dist" requires that we have
-# the Qt build tools, so we *still* need to look for them. We didn't
-# look for Qt, so we don't know what version(s) we have; we look for
-# whatever version we can find.
-#
-# XXX - but the above comment about Qt 4 vs. Qt 5 means that if we
-# ship files built with the uic from one version of Qt, they won't
-# compile with another major version of Qt, so should we be shipping
-# those files? If we don't, that means somebody building from a
-# source tarball would need to have the Qt tools installed, but
-# they'll need other developer packages of Qt *anyway*.
-#
-AC_WIRESHARK_QT_TOOL_CHECK(UIC, uic, "$qt_version")
-AC_SUBST(UIC)
-AC_WIRESHARK_QT_TOOL_CHECK(MOC, moc, "$qt_version")
-AC_SUBST(MOC)
-AC_WIRESHARK_QT_TOOL_CHECK(RCC, rcc, "$qt_version")
-AC_SUBST(RCC)
-
# Error out if a glib header other than a "top level" header
# (glib.h, glib-object.h, gio.h) or certain other headers( e.g.,gmodule.h)
# is used.