aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-07-31 20:40:19 +0000
committerGuy Harris <guy@alum.mit.edu>2013-07-31 20:40:19 +0000
commit7bad1f75dac8a6022e8c1e2fb188d6a0ffda938c (patch)
tree831cfaae1bde117a95368711eaf2101f6bc0fbac /configure.ac
parentee9c3082a896841c09d8e07cfb8a4dcfeccdac2c (diff)
Only use sw_vers if we're on OS X.
svn path=/trunk/; revision=51074
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 16 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b139f09b85..3ec8ccad7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -437,13 +437,23 @@ then
esac
else
#
- # In the installer package XML file, give the current OS
- # version, minor version and all, as the minimum version.
- # We can't guarantee that the resulting binary will work
- # on older OS versions, not even older minor versions
- # (original release or earlier software updates).
+ # Is this OS X?
#
- OSX_MIN_VERSION=`sw_vers -productVersion`
+ case "$host_os" in
+ darwin*)
+ #
+ # Yes.
+ #
+ #
+ # In the installer package XML file, give the current OS
+ # version, minor version and all, as the minimum version.
+ # We can't guarantee that the resulting binary will work
+ # on older OS versions, not even older minor versions
+ # (original release or earlier software updates).
+ #
+ OSX_MIN_VERSION=`sw_vers -productVersion`
+ ;;
+ esac
fi
AC_SUBST(OSX_MIN_VERSION)