aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-06-09 16:37:12 -0700
committerGuy Harris <guy@alum.mit.edu>2015-06-09 23:37:52 +0000
commit3944e5563365cdd51a3a6ca3d55cff88d3bd4a25 (patch)
treeb32f5bc1b00e66d57fc121b791804f147d1ef81b /configure.ac
parentcc1849b67ed986472bed3eaafcefdd535749bec7 (diff)
Clean up --with-qt handling.
If you don't specify --with-qt or --without-qt, we build with Qt iff we find it; we don't fail if we don't find it. If you specify --with-qt, we build with Qt if we find it and fail if we don't find it. If you specify --without-qt, we don't look for Qt and don't build with it. This is all independent of --with-gtk2 or --with-gtk3. Change-Id: I508d3281192bda9168fc46aba6011687c83ef818 Reviewed-on: https://code.wireshark.org/review/8861 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 13 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3e8b031af7..1856a4f6be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1640,10 +1640,23 @@ if test "x$enable_wireshark" = "xyes"; then
CXXFLAGS="$CXXFLAGS $Qt_CFLAGS"
have_qt=yes
GUI_CONFIGURE_FLAGS="$GUI_CONFIGURE_FLAGS --with-qt"
+
+ #
+ # XXX - greasy hack to make ui/gtk/recent.c
+ # compile.
+ #
+ CPPFLAGS="-DQT_GUI_LIB"
],
[
case "$with_qt" in
+ unspecified)
+ #
+ # They didn't explicitly ask for Qt,
+ # so just don't build with it.
+ #
+ ;;
+
yes)
AC_MSG_ERROR([Qt is not available])
;;
@@ -1657,12 +1670,6 @@ if test "x$enable_wireshark" = "xyes"; then
;;
esac
])
-
- #
- # XXX - greasy hack to make ui/gtk/recent.c
- # compile.
- #
- CPPFLAGS="-DQT_GUI_LIB"
fi
if test "x$with_gtk3" = "xyes"; then