aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Kaiser <wireshark@kaiser.cx>2015-03-08 13:11:47 +0100
committerMartin Kaiser <wireshark@kaiser.cx>2015-03-08 12:18:12 +0000
commit1a572019fea761157e214299355f8dbaee7c183f (patch)
treec573b3554162e3ba4c368c3a97d41b179e800f65 /configure.ac
parentfa2a15e67348d4e50de46324a59d8cd802b3bb81 (diff)
Revert "[Qt translations] create the .qm files during the build"
This reverts commit 7d01a84d0e2833f685b7e70c3a52097891286566. cmake doesn't get the dependencies right if the .qm files are gone I'll work on this off-line and resubmit it as one commit rather than trying to approach this step-by-step Change-Id: Ibbd60163f910adbd571b3df2a980d64dbf1ea924 Reviewed-on: https://code.wireshark.org/review/7596 Reviewed-by: Martin Kaiser <wireshark@kaiser.cx> Tested-by: Martin Kaiser <wireshark@kaiser.cx>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 11e90e0c5f..06a3d890d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1877,29 +1877,6 @@ then
fi
AC_SUBST(RCC)
-AC_PATH_PROG(LRELEASE, lrelease)
-if test "x$LRELEASE" = x; then
- AC_PATH_PROG(LRELEASE, lrelease-qt5)
- if test "x$LRELEASE" = x; then
- AC_PATH_PROG(LRELEASE, lrelease-qt4)
- fi
-fi
-# Debian/Ubuntu ship a package qtchooser that installs placeholders for
-# the Qt tools like lrelease - check if the lrelease that we found is
-# really the one that's part of Qt linguist
-if (test "x$LRELEASE" != x) ; then
- AC_MSG_CHECKING([if $LRELEASE is usable])
- if (sh -c $LRELEASE -help 2> /dev/null | grep -i linguist 2>&1 > /dev/null ) ; then
- AC_MSG_RESULT(yes)
- have_lrelease="yes"
- AC_SUBST(LRELEASE)
- else
- AC_MSG_RESULT(no)
- have_lrelease="no"
- fi
-fi
-AM_CONDITIONAL(HAVE_LRELEASE, test "x$have_lrelease" = "xyes")
-
# Error out if a glib header other than a "top level" header
# (glib.h, glib-object.h, gio.h) or certain other headers( e.g.,gmodule.h)
# is used.