aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2014-05-22 21:44:06 +0200
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2015-02-18 18:05:53 +0000
commit0dd7714d4da9824cc1294d6e200dfc9f44fba182 (patch)
treefbb951d002e3ce538863105318039347a874d6f3 /configure.ac
parentb35688760a6827639ecb4e1230d1a181e5048342 (diff)
Add AddressSanitizer (ASAN) build option
--enable-asan for autotools -D ENABLE_ASAN:BOOL=TRUE for CMake Need Clang/LLVM >= 3.1 or GCC >= 4.9 More information about ASAN https://code.google.com/p/address-sanitizer/wiki/AddressSanitizer Change-Id: I833d4216d9508b8f7550ebc1dff6326734bdb53a Reviewed-on: https://code.wireshark.org/review/1727 Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dd0b50234b..d1ec39a17e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -922,6 +922,24 @@ AC_ARG_ENABLE(extra-compiler-warnings,
fi
],)
+# Try to add ASAN address analyze.
+# Only needed for analyse
+#
+AC_ARG_ENABLE(asan,
+ AC_HELP_STRING( [--enable-asan],
+ [Enable AddressSanitizer (ASAN) for debugging (May be slow down)@<:@default=no@:>@]),
+[
+ #
+ # With Clang >= 3.5 Leak detection is enable by default
+ # and no yet all leak is fixed...
+ # use ASAN_OPTIONS=detect_leaks=0 to disable detect_leaks
+ #
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-fsanitize=address)
+
+],)
+
+
+
#
# The following are for C and C++
#