aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-01-03 22:16:53 +0000
committerGuy Harris <guy@alum.mit.edu>2013-01-03 22:16:53 +0000
commitfe350d7cbd79f4a8a54b2ab29d63c6a7638f8831 (patch)
tree69600fa0b7b2f8fc2beec06577aa01d61db2b66d /configure.ac
parent70d24388518f98dc8684411c599a349fe2ea473a (diff)
On the Ubuntu buildbot, this says -Wlogical-op doesn't work, but it
worked OK before. In the test program, try declaring foo() before defining it, in case the problem is that --enable-extra-gcc-checks enables checking for functions that weren't declared before they were defined, so the lack of that declaration may have caused a separate warning. svn path=/trunk/; revision=46924
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 93aa3e1720..c0d7b2ccae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -477,6 +477,8 @@ AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wlogical-op, C,
[
#include <string.h>
+extern int foo(char *, int);
+
int
foo(char *sep, int c)
{