aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-15 12:16:46 +0100
committerJoão Valverde <j@v6e.pt>2017-10-16 18:38:20 +0000
commitdbbaa41362647569c0087c212e908c2ac570cbb7 (patch)
tree4b0bed513820de7967caaff48c04d8206349ab23 /configure.ac
parent0d6c5a79eb75e10f1d13b160c18a32c0bf57a2d7 (diff)
autotools: remove some macOS specific build options
This treats macOS/OSX like any other Unix-like build target, thus removing autotools support for macOS-specific build options. Anyone needing that is advised to use the fully-supported-on-macOS CMake build. Change-Id: I631464a90e16e3db89538801c741657a0a4a7451 Reviewed-on: https://code.wireshark.org/review/23911 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 2d32b878d2..fd0bb32bbd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,11 +226,6 @@ if test -z "$PKG_CONFIG"; then
fi
#
-# Add configure argument to select macOS deployment target.
-#
-AC_WIRESHARK_OSX_DEPLOY_TARGET
-
-#
# Try to arrange for large file support.
#
AC_SYS_LARGEFILE
@@ -461,14 +456,6 @@ AC_SUBST(A2X_LYNX)
# RPM
AC_CHECK_PROGS(RPMBUILD, [rpmbuild], [rpmbuild])
-#
-# Use this as a proxy for "is this macOS" (just in case somebody actually
-# built and installed Darwin as an OS, perhaps with some X11-based GUI,
-# don't look for Darwin).
-#
-AC_CHECK_PROG(have_sw_vers, sw_vers, "yes", "no")
-AM_CONDITIONAL(NOT_MACOS, test "x$have_sw_vers" = "xno")
-
# Shellcheck
AC_CHECK_PROGS(SHELLCHECK, shellcheck, shellcheck)