aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-08-27 13:55:14 -0700
committerGuy Harris <guy@alum.mit.edu>2017-08-27 20:55:45 +0000
commitd846a3e8b9908caa65d182b680efb82c56c8103f (patch)
tree9cee64f1ad10a054b8fa09c0ace50cfcc1976251 /configure.ac
parentef3b7a3394d918a7abebbd410a3525fd3b212ba3 (diff)
Add -Wused-but-marked-unused as an extra warning flag.
We can't just turn it on yet, because that would require generators to know which generated functions use which parameters and mark only the unused ones as such. The generator that turns PIDL files into DCE RPC dissectors is one that would have to be fixed. Change-Id: I42013c8983d01fd3eca4026358b37ba043f12190 Reviewed-on: https://code.wireshark.org/review/23246 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8a28ba7e5..7800cf809f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -755,6 +755,13 @@ AC_ARG_ENABLE(extra-compiler-warnings,
# never enable this one with -Werror.
#
AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wbad-function-cast, C)
+
+ #
+ # This causes some generated files to fail with -Werror;
+ # fixing that would require the generator to figure
+ # out in which functions use which parameters.
+ #
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-Wused-but-marked-unused, C)
fi
])