aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2017-07-26 23:23:12 +0200
committerAnders Broman <a.broman58@gmail.com>2017-07-30 05:22:35 +0000
commit3e54cabf8193e6a8cd607b1671defb8b6800b53d (patch)
tree63297098c0c26c1c875ab0959d9679d70b3c6e65 /configure.ac
parent32b446d5a8f146565b81324d1a18bcb053e07c5f (diff)
Add G.729 decoding based on bcg729 library
Bug: 13635 Change-Id: Ic22a0719a59da13e51425aeb747e88caca0d6512 Reviewed-on: https://code.wireshark.org/review/22808 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4da9b93646..46904d88fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2567,6 +2567,35 @@ fi
AM_CONDITIONAL(HAVE_SPANDSP, test "x$have_spandsp" = "xyes")
#`
+# Check bcg729 library for RTP Player
+# https://www.linphone.org/technical-corner/bcg729/overview
+dnl bcg729 Check
+BCG729_LIBS=''
+AC_MSG_CHECKING(whether to use the bcg729 library if available)
+
+AC_ARG_WITH([bcg729],
+ AC_HELP_STRING( [--with-bcg729=@<:@=DIR@:>@],
+ [use bcg729 to play G.729 codec(located in directory DIR, if supplied) @<:@default=yes, if present@:>@]),
+[
+if test "x$withval" = "xno"; then
+ want_bcg729=no
+elif test "x$withval" = "xyes"; then
+ want_bcg729=yes
+elif test -d "$withval"; then
+ want_bcg729=yes
+ AC_WIRESHARK_ADD_DASH_L(WS_LDFLAGS, ${withval}/lib)
+fi
+])
+if test "x$want_bcg729" = "xno"; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_WIRESHARK_BCG729_CHECK
+fi
+AC_SUBST(BCG729_LIBS)
+AM_CONDITIONAL(HAVE_BCG729, test "x$have_good_bcg729" = "xyes")
+
+#`
# Libxml2 check
AC_ARG_WITH(libxml2,
AC_HELP_STRING([--with-libxml2=@<:@yes/no@:>@],
@@ -3146,6 +3175,12 @@ else
nghttp2_message="no"
fi
+if test "x$have_good_bcg729" = "xyes" ; then
+ bcg729_message="yes"
+else
+ bcg729_message="no"
+fi
+
echo ""
echo " CPPFLAGS: $WS_CPPFLAGS $CPPFLAGS"
echo ""
@@ -3206,6 +3241,7 @@ echo " Have ssh_userauth_agent : $ssh_userauth_agent_message"
echo " Use nl library : $libnl_message"
echo " Use SBC codec library : $have_sbc"
echo " Use SpanDSP library : $have_spandsp"
+echo " Use bcg729 library : $bcg729_message"
echo " Use libxml2 library : $have_libxml2"
echo " Use nghttp2 library : $nghttp2_message"
echo " Use LZ4 library : $have_lz4"