aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-15 19:58:55 +0100
committerJoão Valverde <j@v6e.pt>2017-10-16 20:31:00 +0000
commit356d6b8db04bfc15a1d0a5fabbc79aad0e81d592 (patch)
treeb346c363b55304db2fc5a81b0498c5e4027063d0 /configure.ac
parent0a3cf5d5cf09c17afd06c64172780b4a02acdb62 (diff)
GTK: Remove OSX integration library support
Only Wireshark Qt is officially supported on macOS. Change-Id: Id0e3429891173d4b91e99061bcf11df2e38bc0bf Reviewed-on: https://code.wireshark.org/review/23931 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 0 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index fd0bb32bbd..16852cba05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1515,36 +1515,6 @@ if test "$ac_cv_glib_supports_printf_grouping" = yes ; then
AC_DEFINE(HAVE_GLIB_PRINTF_GROUPING, 1, [Define if GLib's printf functions support thousands grouping.])
fi
-if test "x$have_gtk" = "xyes"
-then
- #
- # We have GTK+; do we want the macOS integration functions and,
- # if so, do we have them and, if so, which versions do we have,
- # the old Carbon-based ones or the new Cocoa-based ones?
- #
- AC_MSG_CHECKING(whether to use macOS integration functions)
-
- AC_ARG_WITH(osx-integration,
- AC_HELP_STRING( [--with-osx-integration],
- [use macOS integration functions @<:@default=yes, if available@:>@]),
- [
- if test $withval = no
- then
- want_osx_integration=no
- else
- want_osx_integration=yes
- fi
- ],[
- want_osx_integration=yes
- ])
- if test "x$want_osx_integration" = "xno"; then
- AC_MSG_RESULT(no)
- else
- AC_MSG_RESULT(yes)
- AC_WIRESHARK_OSX_INTEGRATION_CHECK
- fi
-fi
-
AC_SUBST(wireshark_bin)
AC_SUBST(wireshark_man)
AC_SUBST(wireshark_SUBDIRS)