aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-23 19:46:16 +0100
committerMichael Mann <mmann78@netscape.net>2017-10-23 19:13:40 +0000
commit12d63c428f973b1f7e04ad58d432d778e2035a9a (patch)
treec321627469c1dd4b7c56ae58b1b58aa5c3f3ef33 /configure.ac
parent6014bfe6fc06786cd074bd66cda210b9aafa7d36 (diff)
configure: Remove ancient inet_pton test for brokenness
Change-Id: Idac71883b6a1c6c78ae79e929f1c67a295ed9035 Reviewed-on: https://code.wireshark.org/review/24037 Reviewed-by: Guy Harris <guy@alum.mit.edu> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 1 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index da96de3623..31846ad86d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2439,35 +2439,7 @@ if test "x$ac_cv_func_getopt_long" = xyes; then
fi
AC_REPLACE_FUNCS(inet_aton)
-
-AC_CHECK_FUNC(inet_pton, [
- dnl check for pre-BIND82 inet_pton() bug.
- AC_MSG_CHECKING(for broken inet_pton)
- AC_TRY_RUN([#include <sys/types.h>
-#include <sys/socket.h>
-#include <netinet/in.h>
-#include <arpa/inet.h>
-int main()
-{
-#ifdef AF_INET6
- char buf[16];
- /* this should return 0 (error) */
- return inet_pton(AF_INET6, "0:1:2:3:4:5:6:7:", buf);
-#else
- return 1;
-#endif
-}], [AC_MSG_RESULT(ok);
-have_inet_pton=yes], [AC_MSG_RESULT(broken);
-have_inet_pton=no], [AC_MSG_RESULT([cross compiling, assume it is broken]);
-have_inet_pton=no])],
-have_inet_pton=no)
-if test "$have_inet_pton" = no; then
- AC_LIBOBJ(inet_pton)
-else
- AC_DEFINE(HAVE_INET_PTON, 1, [Define to 1 if you have the `inet_pton' function.])
-fi
-
-AC_REPLACE_FUNCS(inet_ntop)
+AC_REPLACE_FUNCS(inet_pton inet_ntop)
AC_REPLACE_FUNCS(strptime)
AC_REPLACE_FUNCS(popcount)