aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-05 17:18:00 +0100
committerJoão Valverde <j@v6e.pt>2017-09-06 08:10:56 +0000
commitd0a91b27f26762e9c998cc5e6fe71767de5d32c7 (patch)
tree9850efb16c84537dba93ee3d6ac8b186036ae00b /configure.ac
parent143bc04ca7c11b4f5a0feef4c01627c9aee6bcd4 (diff)
plugins: config.h must not be included by public headers
For a sane plugin build environment. Include config.h as the first header in the .c file instead. Fix by moving required compiler attribute macros to a new "ws_attributes.h" API header. Change-Id: I34f58a927f68c1a0e59686c14d214825149749e1 Reviewed-on: https://code.wireshark.org/review/23400 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index a8a28ba7e5..738396899c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -939,22 +939,6 @@ dnl build libwsutil_sse42 only if there is SSE4.2
AM_CONDITIONAL(SSE42_SUPPORTED, test "x$have_sse42" = "xyes")
AC_SUBST(CFLAGS_SSE42)
-#
-# If we're running GCC or clang define _U_ to be "__attribute__((unused))"
-# so we can use _U_ to flag unused function parameters and not get warnings
-# about them. Otherwise, define _U_ to be an empty string so that _U_ used
-# to flag an unused function parameters will compile with other compilers.
-#
-# XXX - similar hints for other compilers?
-#
-if test "x$GCC" = "xyes" -o "x$CC" = "xclang" ; then
- AC_DEFINE(_U_, __attribute__((unused)), [Hint to the compiler that a function parameters is not used])
- AC_DEFINE(WS_NORETURN, __attribute((noreturn)), [Hint to the compiler that a function never returns])
-else
- AC_DEFINE(_U_, , [Hint to the compiler that a function parameters is not used])
- AC_DEFINE(WS_NORETURN, , [Hint to the compiler that a function never returns])
-fi
-
# If we're running GCC or CLang, use FORTIFY_SOURCE=2
# (only if the GCC 'optimization level' > 0).
#