aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-07-31 07:39:11 +0000
committerGuy Harris <guy@alum.mit.edu>2013-07-31 07:39:11 +0000
commitb8bc01c74fdff6bfc3b2012d1ba8238a347114d7 (patch)
tree0444a987bb0fd2184bf6a04db50e620cfa462888 /configure.ac
parent559305882501d969884130c8cc8264aa70140595 (diff)
Set the minimum OS X version in the installer package based on the
deployment target; if --disable-osx-deploy-target was specified, set it to the OS version on which we're building - minor/dot-dot version and all - as there's no guarantee that it'll work on *any* version earlier than that. svn path=/trunk/; revision=51060
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a82c0c4424..b139f09b85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -415,6 +415,12 @@ then
#
OSX_DEPLOY_TARGET="MACOSX_DEPLOYMENT_TARGET=$deploy_target"
+ #
+ # In the installer package XML file, give the deployment target
+ # as the minimum version.
+ #
+ OSX_MIN_VERSION="$deploy_target"
+
case $deploy_target in
10.4|10.5)
@@ -429,7 +435,17 @@ then
LDFLAGS="-arch i386 $LDFLAGS"
;;
esac
+else
+ #
+ # In the installer package XML file, give the current OS
+ # version, minor version and all, as the minimum version.
+ # We can't guarantee that the resulting binary will work
+ # on older OS versions, not even older minor versions
+ # (original release or earlier software updates).
+ #
+ OSX_MIN_VERSION=`sw_vers -productVersion`
fi
+AC_SUBST(OSX_MIN_VERSION)
#
# Try to arrange for large file support.
@@ -2747,6 +2763,7 @@ AC_OUTPUT(
packaging/macosx/Info.plist
packaging/macosx/Makefile
packaging/macosx/osx-dmg.sh
+ packaging/macosx/Wireshark_package.pmdoc/index.xml
packaging/nsis/Makefile
packaging/rpm/Makefile
packaging/rpm/SPECS/Makefile