aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-05-03 00:28:42 +0100
committerJoão Valverde <j@v6e.pt>2016-05-16 14:17:12 +0000
commit6aa2d8eedf2644584671fe4d301946c84b6214b6 (patch)
treeccc2898cf6c24fda8108c8c6e687e52df4d96eed /configure.ac
parent9f8fc21b62307da7e63884b677af7e7af84cb5c7 (diff)
configure.ac: Don't require yacc unless it is required
Change-Id: I5e639d867c95eb6f476d5be72e52457a9cc89437 Reviewed-on: https://code.wireshark.org/review/15247 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 15379961e7..aac1c142ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,11 +169,14 @@ fi
#
#
AC_PROG_YACC
-AC_PATH_PROG(YACCDUMMY, $YACC)
-if test "x$YACCDUMMY" = x
-then
- AC_MSG_ERROR(I couldn't find yacc (or bison or ...); make sure it's installed and in your path)
-fi
+dnl Tarballs include the build products and do not require yacc.
+AC_MSG_CHECKING(whether $YACC -V works)
+AS_IF([$YACC -V >/dev/null 2>&1],
+ [AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)
+ AS_IF([test ! -f wiretap/ascend.c],
+ AC_MSG_ERROR([I couldn't find yacc (or bison or ...); make sure it's installed and in your path]))])
+
AM_PROG_LEX
AC_PATH_PROG(LEX, flex)
if test "x$LEX" = x