aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-11-03 12:22:39 +0000
committerJörg Mayer <jmayer@loplof.de>2013-11-03 12:22:39 +0000
commit117a59d7a2998077d5e5163ce1f8d11edd220944 (patch)
tree3354cb559c02db144cb687c6c0497b7be1de9b6d /configure.ac
parent7054372c261ac92233707cfd49851b5e6213826f (diff)
Pass the name of the sed executable as an explicit argurment to
runlex.sh (like it is done with LEX already). May fix a problem on Windows with cmake. svn path=/trunk/; revision=53059
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 13f376aaa1..9fb66d90fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1212,6 +1212,12 @@ esac
#
# Add any checks here that are necessary for other OSes.
#
+AM_PROG_SED
+AC_PATH_PROG(SED, sed)
+if test "x$SED" = x
+then
+ AC_MSG_ERROR(I couldn't find sed; make sure it's installed and in your path)
+fi
AC_WIRESHARK_GNU_SED_CHECK
if test "$HAVE_GNU_SED" = no ; then
case "$host_os" in