aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-22 07:28:17 +0100
committerJoão Valverde <j@v6e.pt>2017-10-26 14:38:40 +0000
commit296a36698b9ff2ab1beb3c21dc8409c3a276001c (patch)
treef7666656d63a7c092b5e13a316a88794d3fd3f4f /configure.ac
parent3bafae200f5b08d386b5a3503023c0e3e2800947 (diff)
configure: Remove profile-build option
Developers should know how to instrument the code for profiling with a given toolchain. This particular case is trivially replaced with: ./configure CFLAGS="-pg" LDFLAGS="-pg" Change-Id: Icc4bca9a8dc5d3ae59a3ff5a8d155f8dc868fcdd Reviewed-on: https://code.wireshark.org/review/24054 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index f320d34ccd..e96d6f2aa5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1096,25 +1096,6 @@ if test x$enable_packet_editor = xyes; then
AC_DEFINE(WANT_PACKET_EDITOR, 1, [Support for packet editor])
fi
-AC_ARG_ENABLE(profile-build,
- AC_HELP_STRING( [--enable-profile-build],
- [build profile-ready binaries @<:@default=no@:>@]),
- enable_profile_build=$enableval,enable_profile_build=no)
-AM_CONDITIONAL(USE_PROFILE_BUILD, test x$enable_profile_build = xyes)
-AC_MSG_CHECKING(if profile builds must be generated)
-if test "x$enable_profile_build" = "xyes" ; then
- if test "x$GCC" = "xyes" -o "x$CLANG" = "xyes" ; then
- AC_MSG_RESULT(yes)
- WS_CFLAGS="-pg $WS_CFLAGS"
- WS_CXXFLAGS="-pg $WS_CXXFLAGS"
- else
- AC_MSG_RESULT(no)
- echo "Building profile binaries currently only supported for GCC and clang."
- fi
-else
- AC_MSG_RESULT(no)
-fi
-
GLIB_MIN_VERSION=2.22.0
AC_SUBST(GLIB_MIN_VERSION)
# GLib checks; we require GLib $GLIB_MIN_VERSION or later, and require gmodule
@@ -3066,7 +3047,6 @@ echo " Use external capture sources : $have_extcap"
echo " Use Lua library : $lua_message"
echo " Build Qt RTP player : $qt_multimedia_message"
echo " Build GTK+ RTP player : $portaudio_message"
-echo " Build profile binaries : $enable_profile_build"
echo " Use pcap library : $want_pcap"
echo " Use zlib library : $zlib_message"
echo " Use kerberos library : $krb5_message"