aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-12-03 23:56:10 -0800
committerGuy Harris <guy@alum.mit.edu>2014-12-04 07:56:48 +0000
commitc02417f851c951ce31b54c4d85934250a9c9df64 (patch)
tree23d93ce7f05e1d079e228a0a2e7bfc7475969d67 /configure.ac
parent6e5d84f1e1ce5cb468f585c0bdb26d555254d107 (diff)
Don't do all the fd.o desktop integration stuff on OS X.
It doesn't need it, so don't install those files, or uninstall them, or suggest running various unnecessary commands after the installation finishes. Change-Id: Ieecab22884723670f47f2fc7cc1ac827f48c1967 Reviewed-on: https://code.wireshark.org/review/5614 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b553b0b9de..0c4dcc1478 100644
--- a/configure.ac
+++ b/configure.ac
@@ -809,6 +809,14 @@ fi
AC_SUBST(HAVE_OSX_PACKAGING)
#
+# Use this as a proxy for "is this OS X" (just in case somebody actually
+# built and installed Darwin as an OS, perhaps with some X11-based GUI,
+# don't look for Darwin).
+#
+AC_CHECK_PROG(have_sw_vers, sw_vers, "yes", "no")
+AM_CONDITIONAL(NOT_OS_X, test "x$have_sw_vers" = "xno")
+
+#
# Some compilers have to be told to fail when passed an unknown -W flag;
# make sure we do that.
#