aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-05-11 23:59:17 +0000
committerGuy Harris <guy@alum.mit.edu>2013-05-11 23:59:17 +0000
commitb7c5f4baa78f7d7d9cd0838c8636c6b67cac057a (patch)
tree212829db5d29070c65bd8c869afd506d980a8190 /configure.ac
parent59417deed4bcce5dbd043cd584b5a0a25736869d (diff)
Add some comments describing what programs are being checked for.
Move DESKTOP_FILE_INSTALL into the group of programs used for packaging; it's used when you install a source package. (It's not used to *build* a source package, but....) svn path=/trunk/; revision=49256
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2a2b0f0d6b..a41a18f80f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,7 +45,7 @@ AC_DEFINE(VERSION_MICRO, version_micro, [Wireshark's micro version])
AM_DISABLE_STATIC
#
-# Checks for programs used in the build process.
+# Checks for programs used in the main build process.
#
AC_PROG_CC
AM_PROG_CC_C_O
@@ -412,7 +412,7 @@ AC_ARG_WITH([gtk3],
AX_LIBSMI
#
-# Program paths
+# Check for programs used when building DocBook documentation.
#
# Check for a2x (convert asciidoc to another format)
@@ -420,8 +420,6 @@ AC_PATH_PROG(A2X, a2x)
AC_CHECK_PROG(HAVE_A2X, a2x, "yes", "no")
AM_CONDITIONAL(HAVE_A2X, test x$HAVE_A2X = xyes)
-AC_PATH_PROG(DESKTOP_FILE_INSTALL, desktop-file-install)
-
# Want to control a tape drive? Use mt. Want to convert HTML to text?
# Uhhhhh... elinks? lynx? w3m? pandoc? html2text?
AC_PATH_PROG(ELINKS, elinks)
@@ -458,6 +456,12 @@ AM_CONDITIONAL(HAVE_XSLTPROC, test x$HAVE_XSLTPROC = xyes)
# For now, we check to see if the various packaging utilites are in our
# path. I'm too lazy to write code to go hunt for them. - Gerald
+#
+# Source packages.
+# (Lets you install the desktop files.)
+#
+AC_PATH_PROG(DESKTOP_FILE_INSTALL, desktop-file-install)
+
# SVR4/Solaris
AC_CHECK_PROG(HAVE_PKGPROTO, pkgproto, "yes", "no")
AC_CHECK_PROG(HAVE_PKGMK, pkgmk, "yes", "no")