aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2014-06-16 17:17:52 -0400
committerJeff Morriss <jeff.morriss.ws@gmail.com>2014-06-16 21:19:28 +0000
commitaeb1888a505cf3783a79bf009ae651d0efb3957e (patch)
treee8c471be2282a0794269c28a43a0339a7d2c7798 /configure.ac
parenta82c8d1cff3081212137c6e2dbcb293268320de3 (diff)
Remove the (old, broken) Python bindings option to ./configure (and a few other references).
Change-Id: I470502bfae6617a798d0c2538f0f04ff7d36fee5 Reviewed-on: https://code.wireshark.org/review/2277 Reviewed-by: Jeff Morriss <jeff.morriss.ws@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 0 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index 8560767bca..436620c388 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2468,46 +2468,6 @@ else
fi
AC_SUBST(GEOIP_LIBS)
-# Warning: this Python scripting appears to be broken (does not work at all).
-# Running it also causes Valgrind to complain about all sorts of memory errors.
-# Suggestion: do not enable it unless you are working on fixing it.
-#
-# An alternative might be https://code.google.com/p/pyreshark/
-#
-dnl Python devel Check
-AC_MSG_CHECKING(whether to use the Python interpreter for scripting)
-
-AC_ARG_WITH(broken-python,
- AC_HELP_STRING( [--with-broken-python@<:@=DIR@:>@],
- [use the (BROKEN) Python interpreter (installed in DIR, if supplied) @<:@default=no@:>@]),
-[
- pythondir='${libdir}/wireshark/python/${VERSION}'
- if test "x$withval" = "xno"
- then
- want_python=no
- elif test "x$withval" = "xyes"
- then
- want_python=yes
- else
- want_python=yes
- pythondir="$withval"
- fi
-],[
- # By default (user didn't explicitly enable Python), don't enable
- # Python support.
- #
- want_python=no
- #pythondir='${libdir}/wireshark/python/${VERSION}'
-])
-if test "x$want_python" = "xno" ; then
- AC_MSG_RESULT(no)
-else
- AC_MSG_RESULT(yes)
- AC_WIRESHARK_PYTHON_CHECK
-fi
-AM_CONDITIONAL(HAVE_LIBPY, test x$want_python != xno)
-AC_SUBST(pythondir)
-
#
# Define WS_MSVC_NORETURN appropriately for declarations of routines that
# never return (just like Charlie on the MTA).
@@ -3000,12 +2960,6 @@ else
lua_message="no"
fi
-if test "x$want_python" = "xno"; then
- python_message="no"
-else
- python_message="yes"
-fi
-
if test "x$want_portaudio" = "xyes" ; then
portaudio_message="yes"
else
@@ -3076,7 +3030,6 @@ echo " Install dumpcap setuid : $setuid_message"
echo " Use dumpcap group : $dumpcap_group_message"
echo " Use plugins : $have_plugins"
echo " Use Lua library : $lua_message"
-echo " Use Python binding : $python_message"
echo " Build rtp_player : $portaudio_message"
echo " Build profile binaries : $enable_profile_build"
echo " Use pcap library : $want_pcap"