aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-06-17 18:22:58 -0700
committerGuy Harris <guy@alum.mit.edu>2014-06-18 01:23:43 +0000
commita61ebef1a5d84e95aa642f18146cb299494a44b9 (patch)
tree464939a3f39a306a5360a34d37c298f443da4b23 /configure.ac
parent666403057122b28d295ac288a897043bf395d86b (diff)
Set the conditional SSE42_SUPPORTED in all circumstances.
This might fix the Solaris/SPARC build error configure: error: conditional "SSE42_SUPPORTED" was never defined. Usually this means the macro was only invoked conditionally. (not all the world's a VAX^Wx86). Change-Id: Ib189ce70b203875188cee3266b8652c02ca34237 Reviewed-on: https://code.wireshark.org/review/2358 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1fde9cd350..582640baa7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -990,12 +990,13 @@ then
]
)
- dnl build libwsutil_sse42 only if there is SSE4.2
- AM_CONDITIONAL(SSE42_SUPPORTED, test "x$have_sse42" = "xno")
-
# Restore CFLAGS
CFLAGS="$CFLAGS_before_simd"
+else
+ have_sse42=no
fi
+dnl build libwsutil_sse42 only if there is SSE4.2
+AM_CONDITIONAL(SSE42_SUPPORTED, test "x$have_sse42" = "xno")
#
# If we're running GCC or clang define _U_ to be "__attribute__((unused))"