aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2018-01-25 14:11:57 +0100
committerGerald Combs <gerald@wireshark.org>2018-01-25 17:17:13 +0000
commit9be01dc6161acb0b11ce82d1e0475d06f8cc1c40 (patch)
tree842dc17a7da79e933c8b6aec5d0cf13a2fe811fb /configure.ac
parent6bd9be470e9c78ed8dfff31912c12eb138f5bf5f (diff)
Qt 4.8 compatibility fixes
Add missing include headers, define Q_NULLPTR for all Qt objects (to avoid having to include an ugly compat header), use old signal/slot syntax (Q_SIGNALS are protected in Qt 4.8), disable Qt 5 log message handler, etc. Change-Id: I449beb0b74050fdfb0fc5828d8fb74eedb2b45bf Reviewed-on: https://code.wireshark.org/review/25469 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 07a03466fe..b0208ae105 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1502,6 +1502,7 @@ AC_SUBST(wireshark_bin)
AC_SUBST(wireshark_man)
AC_SUBST(wireshark_SUBDIRS)
AM_CONDITIONAL(HAVE_Qt, test "$have_qt" = "yes")
+AM_CONDITIONAL(HAVE_QT_VERSION_4, [test $qt_version -eq 4])
AM_CONDITIONAL(HAVE_GTK, test "$have_gtk" = "yes")
# Enable/disable tshark