aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-06-27 23:11:05 +0000
committerGuy Harris <guy@alum.mit.edu>2013-06-27 23:11:05 +0000
commitca9122bfecb043dc5b9203927c65466c6e3252a7 (patch)
tree73be3e3ea5ea5be0299f017f5168d382d0388b5f /configure.ac
parent4504ed0bccc7d5053edd6e307f54329964bf8da6 (diff)
Suppress "Of *COURSE* you're developing a Mac-only application - you're
on a Mac, right? So of *COURSE* you want to use our shiny new frameworks rather than those ugly old open-source multi-platform libraries, right?" warnings. svn path=/trunk/; revision=50200
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 707ed4c442..81103254ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,7 +644,19 @@ bar(void)
[generates warnings from strchr()])
-## AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-error=unused-but-set-variable)
+#
+# On OS X, suppress warnings about deprecated declarations, because
+# they apparently think everything on OS X is Shiny Happy Apple-
+# Framework-Based Apps and are deprecating some perfectly OK
+# multi-platform open-source libraries that we use in our multi-platform
+# open-source application in favor of various frameworks that are
+# OS X-only.
+#
+case "$host_os" in
+darwin*)
+ AC_WIRESHARK_GCC_CFLAGS_CHECK(-Wno-deprecated-declarations)
+ ;;
+esac
#
# Use the faster pre gcc 4.5 floating point precision if available.