aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2013-08-12 20:24:59 +0000
committerGuy Harris <guy@alum.mit.edu>2013-08-12 20:24:59 +0000
commit50eb826406b246d69593afabfac29b0d78ee970e (patch)
tree27f21f2cfc5983d3b0ad05f343621fa018adae3c /configure.ac
parentbebe1200ded4978ab25e42be368ab89552e79294 (diff)
If we're looking for some version of GTK+, and don't find it, fail.
That way, if somebody specifies --with-gtk[23] and that version of GTK+ isn't found, we fail with an indication that the version of GTK+ they asked for isn't there, and if no GUI toolkit was specified, and they didn't explicitly say "don't build Wireshark", we look for GTK+ 3 and, if it's not found, let the user know explicitly. svn path=/trunk/; revision=51323
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 67731951bc..ae23e922fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1325,8 +1325,8 @@ if test "x$enable_wireshark" = "xyes"; then
CFLAGS="$CFLAGS $Qt_CFLAGS"
CXXFLAGS="$CXXFLAGS $Qt_CFLAGS"
have_qt=yes
- ]
- , [AC_MSG_ERROR([Qt is not available])])
+ ],
+ [AC_MSG_ERROR([Qt is not available])])
#
# XXX - greasy hack to make ui/gtk/recent.c
@@ -1353,7 +1353,8 @@ if test "x$enable_wireshark" = "xyes"; then
CFLAGS="$CFLAGS $GTK_CFLAGS"
CXXFLAGS="$CXXFLAGS $GTK_CFLAGS"
have_gtk=yes
- ], have_gtk=no)
+ ],
+ [AC_MSG_ERROR([GTK+ 3 is not available])])
elif test "x$with_gtk2" = "xyes"; then
#
# GTK+ 3 wasn't specified, and GTK+ 2 was specified;
@@ -1364,7 +1365,8 @@ if test "x$enable_wireshark" = "xyes"; then
CFLAGS="$CFLAGS $GTK_CFLAGS"
CXXFLAGS="$CXXFLAGS $GTK_CFLAGS"
have_gtk=yes
- ], have_gtk=no)
+ ],
+ [AC_MSG_ERROR([GTK+ 2 is not available])])
fi
fi