aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-02-19 06:14:10 +0000
committerJoão Valverde <j@v6e.pt>2016-03-03 03:49:08 +0000
commit2bded0b66137a2f1c8b69911d91903a24f8a2624 (patch)
tree0dbcc0a6479b8b29fd6487e3107db39dd4dfcb1a /configure.ac
parent4fca15308968d6fd526eb67497148d2cd6c0b703 (diff)
autotools: Use explicit zlib dependency build flags
Use pkg-config if a zlib.pc file is available. Remove the now redundant AC_TRY_LINK_FUNC test (there are no linker flags for GTK+ here). Change-Id: I7de744749eba7231ae0097b975144b76ffcf1bdb Reviewed-on: https://code.wireshark.org/review/14263 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 7 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index c917542472..9e87f9b68e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2424,8 +2424,11 @@ else
AC_WIRESHARK_PCAP_REMOTE_CHECK
fi
+dnl
dnl zlib check
+dnl
AC_MSG_CHECKING(whether to use zlib for gzip compression and decompression)
+have_zlib=no
AC_ARG_WITH(zlib,
AC_HELP_STRING([--with-zlib@<:@=DIR@:>@],
@@ -2442,24 +2445,11 @@ AC_ARG_WITH(zlib,
zlib_dir="$withval"
fi
],[
- #
- # Use zlib if it's present, otherwise don't.
- #
- want_zlib=ifavailable
- zlib_dir=
+ want_zlib="if available"
])
-if test "x$want_zlib" = "xno" ; then
- AC_MSG_RESULT(no)
-else
- AC_MSG_RESULT(yes)
+AC_MSG_RESULT([$want_zlib])
+if test "x$want_zlib" != "xno" ; then
AC_WIRESHARK_ZLIB_CHECK
- if test "x$want_zlib" = "xno" ; then
- AC_MSG_RESULT(zlib not found - disabling gzip compression and decompression)
- else
- if test "x$ac_cv_func_inflatePrime" = "xno" ; then
- AC_MSG_RESULT(inflatePrime not found in zlib - disabling gzipped capture file support)
- fi
- fi
fi
dnl Lua check
@@ -3370,7 +3360,7 @@ else
dumpcap_group_message="$DUMPCAP_GROUP"
fi
-if test "x$want_zlib" = "xno" ; then
+if test "x$have_zlib" = "xno" ; then
zlib_message="no"
else
zlib_message="yes"